Версии php, drush

Цитаты для Друпал 7

У опытных разработчиков в 2019 году сайты работают на PHP 7.2, но все они обновлены и актуальны. Если у вас будет ядро 2015 года, то, конечно, с 7.2 оно работать не будет.

drush нужно выбирать исходя из версии drupal. Для drupal 7 нужен drush 8, а для drupal 8 нужен drush 9

drush 10 ещё в бета версии и я не рекомендую его использовать